Firewall Information
Corner | Corner


Firewall Information
Corner | Corner

Security software installed on your computer protects it against threats from outside your network. A security software suite can contain different types of software such as anti-virus, anti-spyware, firewall, and child protection applications. In addition to your security software’s firewall, your operating system also has a firewall for the same purpose. Although intended to block threats from outside your network, firewalls can sometimes block communication between devices on your network and can cause problems when you use network printers.

For more detailed information on firewalls, click Online Firewall Help on the Firewall dialog.

Common Firewall Issues

Problems you might experience with firewalls include:

• When you install printer software, the printer cannot be found on the network
• You're suddenly unable to print
• The printer shows that it is offline in the "printer" folder on Windows, or the Printers list on a Mac
• HP software shows the printer status as "disconnected" even though the printer is connected to the network
• If you have an All-in-One, some functions, such as printing, work, while others, such as scan, don't

Determining if a Problem is Due to a Firewall

A quick troubleshooting technique is to disable your firewall and see if the problem goes away. Remember to re-enable your firewall before continuing to follow this guide.

Best Practices

Here is a list of best practices that can solve most issues related to firewalls. For specific information on your particular firewall settings, contact the firewall manufacturer.

• Keep your security software up to date. Many security software vendors provide updates that correct known issues and provide the latest defenses against new security threats.
• If your firewall has "High", "Medium", or "Low" security settings, use the "Medium" setting when your computer is connected to your network.
• If you have changed any firewall settings from default, try going back to the default setting.
• If your firewall has a setting called "trusted zone", use this setting when your computer is connected to your network.
• If your firewall has a setting to "not show alert messages", you should disable this. When installing the HP software and using the HP printer you may see alert messages from your firewall software that provide options to "allow", "permit" or "unblock". You should allow any HP software that causes an alert. Also, if the alert has a "remember this action" or "create a rule for this" selection, select it. This is how the firewall learns what can be trusted on your network.
• Do not have more than one firewall enabled at the same time on your computer. An example would be having both the Windows firewall provided by the operating system and a 3rd party firewall enabled at the same time. Having more than one firewall enabled at the same time will not make you computer any safer and may cause problems.
• Use a Manual IP Address To Make Your Printer Connection More Robust.

Your wireless router assigns an address called an IP address to every device on your network. The IP address assigned to a device can change. When this happens, it can sometimes be hard for device software on the computer to find the device over the network. To avoid this potential problem, you can manually assign an IP address to your HP printer. For instructions, see the following section.

Using a Manual IP Address To Make Your Printer Connection More Robust

To set a manual (static) IP address for your printer, it must already be connected to your network.

To set up a manual IP address:

1 Print a Network Configuration Page from the printer's control panel, and note the printer's IP address.

For instructions on printing a Network Configuration Page, see your manual.

2 Type the printer's IP address into an Internet browser to display the printer's internal settings.
3 In the web page that appears, select the Networking tab.
4 On the left side of the page that appears, select Wireless.
5 Select the IPv4 tab.
6 In the content that appears, select Manual IP .
7 Do one of the following:
• If you know the IP address DHCP range (the IP address range that the router automatically sets), enter an IP address outside that range. The first three sets of numbers in the address must match the printer's current IP address. The last set in the IP address must be 2 or more, but no higher than 254.
• If you don't know the DHCP range, enter the printer’s current IP address.
8 Briefly remove the power cord from the router, then plug it back in and let the router reboot.