Informazioni sul firewall
Angolo | Angolo


Informazioni sul firewall
Angolo | Angolo

Il software di protezione installato sul computer lo protegge dalle minacce provenienti dall'esterno della propria rete. Un software di protezione può comprendere tipi di software diversi, come antivirus, anti-spyware, firewall e applicazioni per la protezione dei bambini. Oltre al firewall contenuto nel software di protezione, anche il sistema operativo dispone di un firewall con la stessa finalità. Sebbene siano concepiti per bloccare le minacce provenienti dall'esterno della propria rete, talvolta i firewall possono bloccare le comunicazioni tra i dispositivi all'interno della rete e causare problemi nell'utilizzo delle stampanti di rete.

Per avere informazioni più dettagliate sui firewall, fare clic su Guida al firewall online nella finestra di dialogo del firewall.

Problemi comuni con i firewall

Tra i problemi che si possono riscontrare con i firewall figurano i seguenti:

• Installando il software della stampante, risulta impossibile rilevare la stampante all'interno della rete
• Improvvisamente non è più possibile stampare
• Nella cartella "Stampa" di Windows o nell'elenco delle stampanti del Mac, la stampante viene indicata come "non in linea"
• Il software HP mostra lo stato della stampante come "scollegato", anche se la stampante è connessa alla rete
• Nel caso di dispositivi All-in-One, alcune funzioni, come la stampa, sono accessibili, mentre altre, come la scansione, non lo sono

Come capire quando il problema è dovuto al firewall

Una tecnica rapida per risolvere il problema è quella di disabilitare il firewall e controllare se il problema persiste. Occorrerà ricordarsi di riabilitare il firewall prima di continuare a seguire questa guida.

Best Practice

Ecco un elenco di best practice che possono risolvere la maggior parte dei problemi relativi ai firewall. Per avere informazioni specifiche sulle particolari impostazioni del proprio firewall, contattare il produttore del firewall.

• Mantenere aggiornato il proprio software di protezione. Molti fornitori di software di protezione forniscono aggiornamenti che correggono problemi noti e garantiscono le difese più avanzate nei confronti dei nuovi rischi per la sicurezza.
• Se il firewall è dotato di impostazioni di protezione "Alta", "Media" e "Bassa", utilizzare quella "Media" quando il computer è connesso alla rete.
• Se si è modificata qualche impostazione del firewall rispetto a quelle predefinite, provare a tornare a quelle predefinite.
• Se il firewall dispone di una impostazione chiamata "trusted zone", utilizzarla quando il computer è connesso alla rete.
• Se il firewall dispone di una impostazione per non mostrare i messaggi di avviso, disabilitarla. Durante l'installazione del software HP e quando si utilizza la stampante HP è possibile che il firewall generi dei messaggi con le opzioni per "consentire", "permettere" o "sbloccare". Occorre sbloccare qualunque software HP che generi avvisi. Inoltre, se l'avviso propone una selezione per "ricordare questa azione" o "creare una regola", occorre applicare tale selezione. Questo è il modo in cui il firewall memorizza ciò che attendibile all'interno della rete.
• Non abilitare più di un firewall contemporaneamente sul computer. Un esempio può essere dato dal disporre sia del firewall Windows, fornito dal sistema operativo, che di un firewall di terze parti abilitati contemporaneamente. Più firewall abilitati contemporaneamente non offrono alcuna sicurezza aggiuntiva e possono causare problemi.
• Usare un indirizzo IP manuale per rendere più stabile il collegamento con la stampante

Il router wireless assegna un indirizzo, detto indirizzo IP, a ogni dispositivo che si trova sulla rete. L'indirizzo IP assegnato a un dispositivo può cambiare. Quando questo succede, può talvolta essere difficile per il software installato sul computer rilevare il dispositivo sulla rete. Per evitare questo potenziale problema, è possibile assegnare manualmente un indirizzo IP alla stampante HP. Per maggiori informazioni, vedere il paragrafo seguente.

Usare un indirizzo IP manuale per rendere più stabile il collegamento con la stampante

Per assegnare alla stampante un indirizzo IP manuale (statico), la stampante deve già essere connessa alla rete.

Per configurare un indirizzo IP manuale:

1 Stampare la pagina di configurazione della rete dal pannello di controllo della stampante e prendere nota dell'indirizzo IP della stampante.

Per informazioni su come stampare la pagina di configurazione di rete, vedere il manuale.

2 Digitare l'indirizzo IP della stampante in un browser Internet per visualizzare le impostazioni interne della stampante.
3 Nella pagina Web che viene visualizzata, selezionare la scheda Rete.
4 Sul lato sinistro della pagina così visualizzata, selezionare Wireless.
5 Selezionare la scheda IPv4.
6 Nella finestra visualizzata, selezionare IP manuale .
7 Eseguire una delle operazioni seguenti:
• Se si conosce l'intervallo degli indirizzi IP DHCP (l'intervallo degli indirizzi IP che il router assegna automaticamente), inserire un indirizzo IP al di fuori di tale intervallo I primi tre gruppi di numeri dell'indirizzo devono corrispondere all'indirizzo IP attuale della stampante. L'ultimo gruppo di numeri dell'indirizzo IP deve essere minimo 2, massimo 254.
• Se non si conosce l'intervallo DHCP, inserire l'indirizzo IP attuale della stampante.
8 Staccare per qualche istante il cavo di alimentazione dal router, quindi reinserirlo e attendere che il router si riavvii.