ファイアウォールに関する情報
角 | 角


ファイアウォールに関する情報
角 | 角

お使いのコンピューターにインストールされているセキュリティ ソフトウェアは、ネットワーク外部の脅威からコンピューターを保護します。 セキュリティ ソフトウェア スイートには、ウイルス駆除、スパイウェア駆除、ファイアウォール、児童保護アプリケーションなど、多様なソフトウェアが含まれます。 セキュリティ ソフトウェアのファイアフォールに加え、オペレーティング システムにも同じ目的に使用されるファイアウォールがあります。 ファイアウォールは、ネットワークの外部からの脅威を遮断するためのものですが、ネットワーク上のデバイス間の通信を遮断する場合があり、これによりネットワーク プリンターの使用時に問題が発生することがあります。

ファイアウォールについての詳細は、[ファイアウォール] ダイアログの [オンライン ファイアウォール ヘルプ] をクリックしてください。

一般的なファイアウォールの問題

以下に、ファイアウォールが原因で発生する問題の例をいくつか示します。

• プリンター ソフトウェアをインストールする際に、ネットワーク上でプリンターが見つからない。
• 突然印刷できなくなる。
• 「プリンター」フォルダー (Windows の場合) または プリンタリスト (Mac の場合) でプリンターがオフラインと表示される。
• HP ソフトウェアで、プリンターがネットワークに接続されていてもプリンターのステータスが「接続解除」と表示される。
• All-in-One を使用する場合、印刷などの一部の機能は動作するが、スキャンなどの他の機能が動作しない。

問題の原因がファイアウォールにあるかどうかを確認する

簡単な方法の一つは、ファイアウォールを無効にして、問題が解消するかどうかを確認することです。 このガイドの指示に従って引き続き操作する前に、再度ファイアウォールを有効にしておくことを忘れないでください。

ベスト プラクティス

以下の方法は、ファイアウォールに関する大半の問題を解決できるべスト プラクティスです。 お客様が使用しているファイアウォールの設定についての詳細は、ファイアウォールの製造元にお問い合わせください。

• セキュリティ ソフトウェアは最新状態に保ちます。 多くのソフトウェア ベンダーは、既知の問題を修正し、新しいセキュリティ上の脅威に対する最新の防護策を提供するアップデートを提供しています。
• ファイアウォールのセキュリティ設定に「高」、「中」、「低」がある場合、コンピューターをネットワークに接続するときにはこの設定を「中」にします。
• ファイアウォール設定をデフォルトから変更した場合は、デフォルトの設定に戻します。
• ファイアウォールに「信頼済みゾーン」と呼ばれる設定がある場合、コンピューターをネットワークに接続するときにはその設定を使用します。
• ファイアウォールに「警告メッセージを表示しない」ための設定がある場合、設定を無効にする必要があります。 HP ソフトウェアをインストールし、HP プリンターを使用する場合、「許可」や「ブロックの解除」といったオプションのあるファイアウォール ソフトウェアからの警告メッセージが表示されることがあります。 アラートを発生する HP ソフトウェアを許可する必要があります。 また、警告に「アクションを記憶する」または「ルールを作成する」という選択項目がある場合、それを選択します。 ファイアウォールはこの方法により、ネットワーク上で何が信頼できるかを学習します。
• コンピューター上で複数のファイアウォールを同時に有効にしないでください。 たとえば、Windows オペレーティング システムの Windows ファイアウォールとサードパーティ製のファイアウォールの両方を同時に有効にしている場合があります。 複数のファイアウォールを同時に有効にすると、コンピューターの安全性は強化されず、問題の原因となります。
• プリンターの接続をより堅牢にするために手動 IP アドレスを使用します。

お使いのワイヤレス ルーターによって、IP アドレスと呼ばれるアドレスが、ユーザーのネットワーク上のすべてのデバイスに割り当てられます。 デバイスに割り当てられた IP アドレスは変更される可能性があります。 ただし、ルーターによって割り当てられた IP アドレスが変更されると、コンピューター上のデバイス ソフトウェアがネットワーク上のデバイスを見つけられないことがあります。 このような潜在的な問題を回避するために、HP プリンターに IP アドレスを手動で割り当てることができます。 手順については、次の項を参照してください。

プリンターの接続をより堅牢にするために手動 IP アドレスを使用する

プリンターに手動 (静的) IP アドレスを設定するには、事前にプリンターをネットワークに接続しておく必要があります。

手動 IP アドレスを設定するには：

1 プリンターのコントロール パネルからネットワーク設定ページを印刷し、プリンターの IP アドレスをメモします。

ネットワーク設定ページの印刷手順については、マニュアルを参照してください。

2 インターネット ブラウザーにプリンターの IP アドレスを入力し、プリンターの内部設定を表示します。
3 表示された Web ページで、[ネットワーク] タブを選択します。
4 表示されたページの左側で、[ワイヤレス] を選択します。
5 [IPv4] タブを選択します。
6 表示されたコンテンツで、[手動 IP] を選択します。
7 次のいずれかを実行してください。
• IP アドレスの DHCP の範囲 (ルーターによって自動的に設定される IP アドレスの範囲) がわかっている場合は、その範囲外の IP アドレスを入力します。 アドレスの最初の 3 組の数字は、プリンターの現在の IP アドレスと一致させる必要があります。 IP アドレスの最後の組の数字は、2 ～ 254 の数字である必要があります。
• DHCP の範囲がわからない場合は、プリンターの現在の IP アドレスを入力します。
8 ルーターから電源コードを一時的に抜き、再度接続してルーターを再起動します。